
Easy way to making a photo-realistic 
Condor scenery 

 by Luis Briones 
 

Introduction 

 

First at all, sorry for my English. 

This not pretend be an original work. It's only a way that I can make a scenery. I had troubles to 
process the satellites images follow the tutorials from Tom Berry and P. Strzelec. I found a software 
named SAS.Planet that permit make a photo-realistic scenery in a way that I think that is easier that 
they explain in those tutorials. I worked with both tutorials and I copy part of them in this document. 
I made a lot of trial and error before have a success. I wish that other people don't waste their time 
and use the new software. 

 

I found very good information on http://www.lurik.fr/CondorScenery/ from Lurik. 

 

I use a P. Strzelec document as the basis to write this one. Also, I add things that I learned by reading 
Tom Berry 's tutorial. All italic text is by Luis Briones. Normal text is from P. Strzelec. 

 

I write this make a Low Definition (LD) scenery and I made a High Definition (HD) scenery read and 

follow step by step this tutorial, but may fail… 😊 

 

 

  



I. STRM elevation data 

Needed utilities:  

- Condor Scenery Toolkit (RawtoTrn, LandscapeEditor) - 
http://www.condorsoaring.com/downloads.htm 

- 3Dem – http://www.visualizationsoftware.com/3dem 
 

I found very useful to control my data, the method that Tom Berry write in Section 1 and 
2 of his tutorial. 

 

1. Download SRTM elevation data for the planned scenery from 
http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/  (official), or better yet 
http://www.viewfinderpanoramas.org/dem3.html (better quality/patched);  alternatively, 
search Google for “SRTM data” and download SRTM3 data (90 meter) for the needed region 

 
2. Create a working directory, but not an actual Condor landscape directory (which will be 

created later) 
 
3. Open 3DEM program 

a) Import SRTM data (“Load Terrain Model”) 
b) “F7 Patch Missing Data” 
c) Operation -> Change Projection -> Convert to UTM Projection -> WGS84 (NAD83 

projection frequently used in the U.S. A. is virtually the same and usable) 
d) “F8 Select Smaller Area” – input multiples of 256 (makes life easier), but not greater than 

5120 x 7680 (20 x 30 tiles); write your dimensions down;  
e) “Save USGS ASCII DEM” (SceneryName.dem) 
f) “Save Terrain Matrix” (SceneryName.bin – up to 16 characters, no spaces) 
g) “Save map image” for easy reference 
h) Close 3DEM 
 

4. Rename SceneryName.bin to SceneryName.raw 
 
5. Open RawtoTrn program 

a) Input file dimensions (those multiples of 256) and open 
b) Ignore the red bounding box assuming your scenery is not greater than 20 x 30 Terragen 

tiles 
c) “Save Condor Terrain” remembering to type in the “.trn” extension after the scenery 

name 
d) Close RawtoTrn 



 
6. Open Landscape Editor 

a) File -> New Landscape (select “SceneryName.trn”) 
b) Click on hand icon and zoom out (right-click on scenery) 
c) Check “Draw Terragen Grid” – yellow rectangles should line up with scenery (remember 

multiples of 256?) 
d) “Save Landscape” (your scenery directory was just created in Condor/Landscapes) 
e) Close Landscape Editor 
 

7. Download “Excel Calibration Tools” from http://www.lurik.fr/CondorScenery/00-
Outils/Condor%20Scenery%20Tutorial%20-%20Outils.htm  
a) Open the downloaded Excel file making sure to enable macros 
b) Click “Select HDR File” and select SceneryName.hdr 
c) Click on “Generate Calibration File” and save CalibrationPoints.csv file in the 

“Condor/Landscapes/SceneryName/Working” directory (if unable, save it elsewhere and 
copy over); the existing file should be overwritten 

d) Save the Excel file as “Calibration_SceneryName.xls” for possible future use 
 

8. Open Landscape Editor again 
a) Select “SceneryName” from landscape drop down menu 
b) Click on “Calibration points” just below;  bunch of numbers should show up in the area 

on the left and on the map 
c) Zoom out making sure that calibration points line up with the terragen grid 
d) Click “Calibrate” 
e) File -> Export flightplanner map 
f) File -> Export forest map 
g) File -> Export thermal map 
h) File -> Export textures to DDS (optional, but necessary for steps k-m)) 
i) Tools -> Check for missing files; all files should be present, otherwise redo any of the last 

3 steps 
j) Put your cursor in a flatter area of your scenery and note the coordinates and elevation 
k) Click on “Airports”, in the empty area below right-click and select “Add”, fill in 

coordinates (use all 6 decimal points even if 0’s) 
l) Save landscape and take a Condor test flight on your new ghost-like scenery :-) 

 

  



II. Satellite image data 

Needed utilities:  

- SASPlanet (https://bitbucket.org/sas_team/sas.planet.bin/downloads/) 
QGIS Manual http://docs.qgis.org/2.2/en/docs/training_manual/index.html (In many 
languages) 
There a lot tutorials in Web. One from in youtube: 
https://www.youtube.com/watch?v=LJXl4I7kjEc 

 
1. Open SASPlanet (download your satellite images) 

a) Go to menu Operations->Selection Manager->By Coordinates 
b) Find area a bigger than the final map. Not too much 
c) Put upper and lower corner and push Apply. 
d) Select Download tab. 
e) Select Map/Overlay layer. 
f) Select zoom. 17 is good (1.87m/pixel at 39ºS 68ºW). Check if there are images for this 

zoom before start. 
g) Check Split selection to, parts*: 
h) Choose the big number that system allows. 
i) Maybe do you wish your selection. Click the disk image. 
j) Push Start. This take time, depend of the level of zoom that you choose. Always check the 

method with low details zoom, like 10 or less. You need a lot of free disk space. 60 Gb or 
so. 

 
2. When step one is over  

a) Go to menu Layer->Selection Manager->Last Selection or load from file 
b) Select Stitch tab. 
c) In Output format, select GeoTiff. 
d) Put your path and file name in Save to: 
e) Select your Map: 
f) Choose your zoom. (The same that you use in step one) 
g) Put No in Overlay layer:  
h) Import. Select EPSG:4326 in Projection. 
i) Click Start. This process make the image that you use in Condor. Be pacient!!! 

Ready? Well... Maybe not. I found that SAS.Planet is a 32 bits programs. This means that 
have a 4gb limit in files. You need a few of try and error techniques to find the numbers 
of part that you need to split your image. If you split your image in the number of tiles of 
your scenery work ok (At least in my image using zoom 17) 
I split my 10x14 tiles scenery in 4x8 images. In Stitch tab, you can divide the imagen using 
Row and Column in bottom right part of it.  



III. Orthophotographic HD image data 

Needed utilities:  

- QGIS - Free, open source Geospatial Information System (GIS) software. 
http://www2.qgis.org/en/site/ 

- GIMP2.8.4+ (http://www.gimp.org/downloads/) or Photoshop. 
 
1. Open QGIS 

a) Go to menu Layer ->Add Layer->Add raster layer… and select the files from step 2. 
b) Go to menu Layer ->Add Layer->Add delimited text layer… and select the 

CalibrationPoints.csv. (Maybe it’s better use a copy instead the original) See that File 
Format is CSV, First record has field names unchecked and Geometry definition is Point 
coordinates. Choose field 4 for X field and field 3 for Y Field. Click OK. 

c) Select WGS84 EPSG:4326 and Click OK. 
d) Check if your image is bigger than the calibration points. 

 
2. Go to menu Raster->Miscellaneous->Build virtual raster (Catalog). 

a) Check Choose input directory instead of files. 
b) Select the directory. It will take a few seconds, then a whole bunch of files will show up 

in the lower section of the dialog box. 
c) Use Select to choose the path and name (.vrt) of your Output file. 
d) Uncheck Load into Canvas when finished. 
e) Select the pencil and delete all files name except one. 
f) Delete the actual file name and insert a wildcard. E.g. D:\imagenes\Tutorial/*.tif 
g) Click Ok. 
h) Click Close when the process finished. 

 
3. Go to menu Raster->Projections->Warp (Reproject). 

a) In Input File, choose the vrt file you just built in step 2.c. 
b) Use Select to choose the path and name (.vrt) of your Output file. E.g. Reproj.vrt 
c) Check that Source SRS is EPSG:4326 
d) Check Target SRS and choose the UTM zone for you. 
e) Click Resampling method and choose Cubic Spline. 
f) Click Memory used for caching. If you have it, input 500mb. Above 500mb, the speed is 

not supposed to be appreciably faster. 
g) Click Use multithreaded warping implementation if you have more than one core in 

your processor. 
h) Uncheck Load into canvas when finished. 
i) Select the pencil and delete “-of ADRG”. (Maybe that is not necessary but was the only 

way that works for me) 
j) Click OK and be patient!!! 



k) Click Close when the process finished. 
 

4. Go to menu Project-> Project Properties 
a) Click Enable ‘on the fly’ CRS transformation (OTF). 
b) Select your UTM reference system. 
c) Click OK. 
 

5. Go to menu Raster->Extraction->Clipper… 
a) Select the file from step 3.b in Input file (raster). 
b) Use Select to choose the path and name of your Output file. Ex: Clipped.vrt 
c) In Clipping mode check Extend. 
d) Go to the upper left calibration point and zoom a lot near there. 
e) Click at point and maintain. Move a bit to lower right the mouse. 
f) Write somewhere the values of 1 X,Y. 
g) Go to the lower right and do the same. In this case move the mouse to upper left and 

write de values of 2 X,Y. 
h) Put the values of point f) and g) in 1 X,Y and 2 X,Y 
i) You see a red rectangle that cover your calibrations points. 
j) Click Load into canvas when finished. 
k) Select the pencil and delete “-of ADRG”. 
l) Click OK. 
m) Click Close when the process finished. 
n) Deselect other images in Layers Panel (Left side) 

If all worked ok, the last image has exactly the size of your calibrations points. EUREKA!!! 
 
6. Right click in Layers Panel over the name of the image from step 5.b 

a) Select Save As… 
b) Select Rendered image in Output Mode. 
c) Click Create VRT. 
d) Use Browse to choose the path and name of directory that you use in Save as. You can 

create there. 
e) Verify that in CRS to you have selected your UTM zone. 
f) Uncheck Add saved file to map. 
g) In Resolution (current: layer) click columns. 
h) Put the number of tiles that have your scenery multiplicated for your resolution. For 

example, my scenery has 10 tiles in east-west direction and 14 in north-south. In low 
resolution scenery, I choose 1024 to test the method. 10x1024 = 10240 (left input-
>Columns) 14x1024 =14336 (right input->Rows) 

i) In VRT Tiles put the resolution that you pretend. In my case 1024. 
j) Click OK.  When this process is done, you have a lot of tiles. Only need convert tiff to 

BMP and rename files to import to Condor. 
 



7. Open Gimp or Photoshop to convert Tiff to BMP 
There are many way to convert tiff to BMP. I prefer patch way. There are many examples in 
web. One of this is https://www.youtube.com/watch?v=TIaca4T9hQs 
If you prefer you can touch color too. 
 
Another way is using a program like BulkImageConverter 
 

8. Using your imagination to rename file. I left some clues in Appendix I😉.  Search about .bat 

files. First time I made 5x14 scenery, one by one, by hand, using F2 in explorer 😲 
 

9. Move all tiles to Condor\Landscapes\Scenery_name\Working\Terragen directory 
 

10. Open Landscape Editor  
a) Select SceneryName from drop down menu 
b) Tools -> Import Terragen textures 
c) File -> Export flightplanner map 
d) File -> Export forest map 
e) File -> Export thermal map 
f) File -> Export textures to DDS (this may take several hours) 
g) Tools -> Check for missing files 
h) Save landscape and take a Condor test flight on your new photo-realistic scenery :o) 

_____________________________________________________________________________________ 

last revision on 2017-05-04 

 

  



Appendix I 

QGIS named files from zero using the name of directory where you put. E.g. test.0.tif, test.1.tif, … 

Row 
Columns 

1 2 3 4 5 6 7 8 9 10 

1 0 1 2 3 4 5 6 7 8 9 

2 10 11 12 13 14 15 16 17 18 19 

3 20 21 22 23 24 25 26 27 28 29 

4 30 31 32 33 34 35 36 37 38 39 

5 40 41 42 43 44 45 46 47 48 49 

6 50 51 52 53 54 55 56 57 58 59 

7 60 61 62 63 64 65 66 67 68 69 

8 70 71 72 73 74 75 76 77 78 79 

9 80 81 82 83 84 85 86 87 88 89 

10 90 91 92 93 94 95 96 97 98 99 

11 100 101 102 103 104 105 106 107 108 109 

12 110 111 112 113 114 115 116 117 118 119 

13 120 121 122 123 124 125 126 127 128 129 

14 130 131 132 133 134 135 136 137 138 139 

In the table before you can see the order of the files to made my 10 x 14 scenery. 

Condor use other order as you can see in the following table: 

Slice 9 Slice 8 Slice 7 Slice 6 Slice 5 Slice 4 Slice 3 Slice 2 Slice 1 Slice 0 

0913 0813 0713 0613 0513 0413 0313 0213 0113 0013 

0912 0812 0712 0612 0512 0412 0312 0212 0112 0012 

0911 0811 0711 0611 0511 0411 0311 0211 0111 0011 

0910 0810 0710 0610 0510 0410 0310 0210 0110 0010 

0909 0809 0709 0609 0509 0409 0309 0209 0109 0009 

0908 0808 0708 0608 0508 0408 0308 0208 0108 0008 

0907 0807 0707 0607 0507 0407 0307 0207 0107 0007 

0906 0806 0706 0606 0506 0406 0306 0206 0106 0006 

0905 0805 0705 0605 0505 0405 0305 0205 0105 0005 

0904 0804 0704 0604 0504 0404 0304 0204 0104 0004 

0903 0803 0703 0603 0503 0403 0303 0203 0103 0003 

0902 0802 0702 0602 0502 0402 0302 0202 0102 0002 

0901 0801 0701 0601 0501 0401 0301 0201 0101 0001 

0900 0800 0700 0600 0500 0400 0300 0200 0100 0000 



With some work, I can make an excel table like this follow Tom Berry’s spreadsheet method: 

1 
Desired scenery 
size in terragens    

2 Width  Height     
3 10 14    
…      
7 Col Y Row x Condor QGIS Order 

8 1 1 0913 test.0 copy test.0.bmp ..\FinalBMP\0913.bmp 
9 1 2 0912 test.10 copy test.10.bmp ..\FinalBMP\0912.bmp 

10 1 3 0911 test.20 copy test.20.bmp ..\FinalBMP\0911.bmp 
11 1 4 0910 test.30 copy test.30.bmp ..\FinalBMP\0910.bmp 
12 1 5 0909 test.40 copy test.40.bmp ..\FinalBMP\0909.bmp 
…      

 10 11 0003 test.109 copy test.109.bmp ..\FinalBMP\0003.bmp 

 10 12 0002 test.119 copy test.119.bmp ..\FinalBMP\0002.bmp 

 10 13 0001 test.129 copy test.129.bmp ..\FinalBMP\0001.bmp 

 10 14 0000 test.139 copy test.139.bmp ..\FinalBMP\0000.bmp 
 

I put the values of Col and Row by hand using copy and paste. To made the other thing I used the 
concatenate order. First time that I use it. 

https://support.office.com/en-us/article/CONCATENATE-function-8f8ae884-2ca8-4f7a-b093-
75d702bea31d 

Condor Value: 
=CONCATENATE(0,$A$3-A8,IF($B$3-B8> 9,$B$3-B8,CONCATENATE(0,$B$3-B8))) 

QGIS Value: 
=CONCATENATE($F$3,".",(B8-1)*10+(A8-1)) 

Order Value: 
=CONCATENATE("copy ",D8,".bmp"," ..",$F$1,"\",C8,".bmp") 

$F$1 = test 

  


